HP Lefthand OS 10.0 upgrade issue with certain management group password strings

A few weeks ago HP released the new Lefthand OS 10.0 for their StoreVirtual products. I’ve since upgraded my VSA clusters successfully,  however, when attempting this on a test P4300 cluster I ran into some weird issues.

During the upgrade (which now has a nice progress window) the first node in the cluster would upgrade OK but upon rebooting would not reconnect to the CMC. When trying to log into the direct console on the upgraded node it would not accept my Management Group (MG) password. I had no other option but to forcibly cancel the upgrade and I rebuilt the failed node.

After attempting a subsequent upgrade, the same problem occurred. This time I noticed in the status bar in the CMC that it was failing to log into the newly upgraded node and said the username and password was incorrect! As a result I logged a job with HP.

The response I received was rather interesting…as it turns out they have had several incidences similar and are related to MG passwords containing the characters ‘~‘ or ‘$‘.

So, this got me thinking…if the password is corrupted by the upgrade, what happens if I try logging in with a partial password? I tried several combinations on my test cluster until VIOLA, I could log in with the first part of the password leading up until the special character!

To clarify this, lets say our MG password was abc123$def, after the upgrade the CMC will fail to reconnect. You should be able to log into the node using abc123, i.e. we’ve dropped the $ symbol and anything after that. I’m not sure what happens if your password begins with those characters…could be interesting as the CMC does not allow a blank password!

I would imagine HP will release a patch for this in the coming weeks, in the meantime you could change your MG passwords prior to the upgrade 🙂

Anyway, I hope this helps others out there, I’ve been pulling my hair out over the last week with rebuilding nodes!!!

Update: This bug seems to affect even newly built 10.0 nodes from scratch, however HP have released an update to 10.0 now supposedly fixing this issue.

Advertisements

About Ben Loveday
My name is Ben Loveday and I am working as a Systems Architect in New Zealand. I have a keen interest in VMware products and are VCAP5-DCD, VCAP5-DCA and Microsoft MCITP certified. I am studying towards VCDX5 certification…I hope! My areas of focus are the virtualisation of manufacturing automation systems with the aim to improve traditional automation/SCADA system design and improve their availability and reliability. I am married with three kids and my hobbies include playing the guitar (less often than I’d like) and listening to music, mostly 80′s Metal and Rock/Blues :-) Oh..and I'm a PC gamer!

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s